Thursday, December 24, 2009

Cygwin 1.7 upgrade breaks Perl due to missing libssp0 dependency

After upgrading Cygwin to version 1.7, Perl failed with the following error message:

/usr/bin/perl.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

Then I ran "cygcheck /usr/bin/perl" and saw a bunch of these errors:

cygcheck: track_down: could not find cygssp-0.dll

I then installed libssp0 (current version 4.3.4-3), and Perl worked properly.

9 comments:

Brink said...

Thanks for the post! This helped me resolve my problem with it

Anonymous said...

Me too, thanks a lot and merry Christmas!

Yufeng said...

I got the same problem. Thanks!

ReallyVirtual said...

Thanks, saved me a lot of time.

somo said...

Thanks for your solution!!!
well... I spend almost 2 weeks to solve this problem..
Now my perl can work now.
and Merry Christmas!

Abhik said...

Thanks a lot! This helped me too.

Sanjay said...

Thank you !! This helped me resolve my problem with ssh.

Anon8AWaPuTE said...

There is a simpler way:
rerun cygwin installer, filter instakked packages by "ssp", check that libssp is installed, then uncheck-and-check-back this library and let installer done its job. libssp0 becomes installed.

abcd@

Fernando said...

me ajudou obrigado. thank you!!!